summaryrefslogtreecommitdiff
path: root/src/printer/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-11-15 22:57:14 +0000
committerMorgan Deters <mdeters@gmail.com>2010-11-15 22:57:14 +0000
commit5e5956d492ab18b5b4d4bb51117ac760867a525d (patch)
tree0c151baa58810722288ad986dfa13123de273739 /src/printer/Makefile.am
parentec4e1bdba56565d6372cb19ded12c9cadc506870 (diff)
Pretty-printer infrastructure created (in src/printer) and SMT-LIBv2 printer
implemented. This new infrastructure removes support for pretty-printing (even in the AST language) an Expr with reference count 0. Previously, this was supported in a few places internally to the expr package, for example in NodeBuilder. (Now, a NodeBuilder cannot be prettyprinted, you must extract the Node before printing it.)
Diffstat (limited to 'src/printer/Makefile.am')
-rw-r--r--src/printer/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/printer/Makefile.am b/src/printer/Makefile.am
new file mode 100644
index 000000000..8fd50d823
--- /dev/null
+++ b/src/printer/Makefile.am
@@ -0,0 +1,21 @@
+AM_CPPFLAGS = \
+ -D__BUILDING_CVC4LIB \
+ -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/..
+AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
+
+noinst_LTLIBRARIES = libprinter.la
+
+libprinter_la_SOURCES = \
+ printer.h \
+ printer.cpp \
+ ast/ast_printer.h \
+ ast/ast_printer.cpp \
+ smt/smt_printer.h \
+ smt/smt_printer.cpp \
+ smt2/smt2_printer.h \
+ smt2/smt2_printer.cpp \
+ cvc/cvc_printer.h \
+ cvc/cvc_printer.cpp
+
+libprinter_la_LIBADD = \
+ @builddir@/../lib/libreplacements.la
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback