summaryrefslogtreecommitdiff
path: root/src/parser/tptp/Makefile.am
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-10-19 14:45:42 -0700
committerGitHub <noreply@github.com>2018-10-19 14:45:42 -0700
commitce8c429281fd1f7e4ac4d2b7133152c1d370df0c (patch)
tree407400e728621cc9a5262e7112a93bd6acd0835a /src/parser/tptp/Makefile.am
parent7de0540252b62080ee9f98617f5718cb1ae08579 (diff)
Remove autotools build system. (#2639)
Diffstat (limited to 'src/parser/tptp/Makefile.am')
-rw-r--r--src/parser/tptp/Makefile.am69
1 files changed, 0 insertions, 69 deletions
diff --git a/src/parser/tptp/Makefile.am b/src/parser/tptp/Makefile.am
deleted file mode 100644
index 43bbc595d..000000000
--- a/src/parser/tptp/Makefile.am
+++ /dev/null
@@ -1,69 +0,0 @@
-AM_CPPFLAGS = \
- -D__BUILDING_CVC4PARSERLIB \
- -I@builddir@/../.. -I@srcdir@/../../include -I@srcdir@/../.. $(ANTLR_INCLUDES)
-AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN) $(WNO_PARENTHESES) $(WNO_TAUTOLOGICAL_COMPARE) -Wno-unused-function -Wno-unused-variable
-
-# Compile generated C files using C++ compiler
-AM_CFLAGS = $(AM_CXXFLAGS)
-CFLAGS=$(CXXFLAGS)
-CC=$(CXX)
-
-ANTLR_OPTS =
-
-# hide this included makefile from automake
-@mk_include@ @srcdir@/../Makefile.antlr_tracing
-
-noinst_LTLIBRARIES = libparsertptp.la
-
-ANTLR_TOKEN_STUFF = \
- @builddir@/Tptp.tokens
-ANTLR_LEXER_STUFF = \
- @builddir@/TptpLexer.h \
- @builddir@/TptpLexer.c \
- $(ANTLR_TOKEN_STUFF)
-ANTLR_PARSER_STUFF = \
- @builddir@/TptpParser.h \
- @builddir@/TptpParser.c
-ANTLR_STUFF = \
- $(ANTLR_LEXER_STUFF) \
- $(ANTLR_PARSER_STUFF)
-
-libparsertptp_la_SOURCES = \
- Tptp.g \
- tptp.h \
- tptp.cpp \
- tptp_input.h \
- tptp_input.cpp \
- $(ANTLR_STUFF)
-
-BUILT_SOURCES = \
- @builddir@/Tptp.tokens \
- @builddir@/TptpLexer.h \
- @builddir@/TptpLexer.c \
- @builddir@/TptpParser.h \
- @builddir@/TptpParser.c \
- stamp-generated
-
-EXTRA_DIST = \
- stamp-generated
-
-DISTCLEANFILES = $(ANTLR_STUFF)
-distclean-local:
- -$(AM_V_at)rmdir generated
- -$(AM_V_at)rm -f stamp-generated
-
-stamp-generated:
- $(AM_V_at)mkdir -p generated
- $(AM_V_at)touch stamp-generated
-
-# antlr doesn't overwrite output files, it just leaves them. So we have to delete them first.
-@builddir@/TptpLexer.h: Tptp.g stamp-generated
- -$(AM_V_at)rm -f $(ANTLR_STUFF)
- @if test -z "$(ANTLR)"; then echo "ERROR: antlr parser generator cannot be found, cannot generate the parser" >&2; exit 1; fi
- $(AM_V_GEN)$(ANTLR) $(ANTLR_OPTS) -fo "@builddir@" "@srcdir@/Tptp.g"
-
-# These don't actually depend on TptpLexer.h, but if we're doing parallel
-# make and the lexer needs to be rebuilt, we have to keep the rules
-# from running in parallel (since the token files will be deleted &
-# recreated)
-@builddir@/TptpLexer.c @builddir@/TptpParser.h @builddir@/TptpParser.c $(ANTLR_TOKEN_STUFF): @builddir@/TptpLexer.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback