summaryrefslogtreecommitdiff
path: root/src/parser/smt/Makefile.am
diff options
context:
space:
mode:
authorDejan Jovanović <dejan.jovanovic@gmail.com>2009-12-06 02:21:46 +0000
committerDejan Jovanović <dejan.jovanovic@gmail.com>2009-12-06 02:21:46 +0000
commitc16be5841e613818d5764e4de99e4694a0703685 (patch)
tree5bf7c07a8f7200c2830d50f5dd83ecbb4f02444d /src/parser/smt/Makefile.am
parent200f36785acf7aac3e7e230795ea7ffdb6b1ed64 (diff)
Big chunk of changes:
* Fixed bugs in option parsing * Simplified the main.cpp significantly (more c++ like) * Added the null kind, expr value, and expression, with the default constructor public * Simplified commands, we need to discuss this in the meeting (what to do with command results?) * Removed all the lex/yacc files * Symbol table is now a templated class, as we will have tables for variables, predicates and functions * The ANTLR parsing infrastructure/makefiles is all in. SMT lib Boolean benchmarks should parse + giving nice error such as Parse Error: /home/dejan/eclipse-cxx/smtlib-parser/test/test4.smt:3:16: Undeclared variable p Parse Error: /home/dejan/eclipse-cxx/smtlib-parser/test/test2.smt:2:11: unexpected token: sa Didn't add any unit tests as the unit testing doesn't work with the updated build system -- it doesn't know how to create directories in the corresponding build directory. TODO: * add the PL grammar and unit test when the testing becomes available * with this build setup my eclipse debugger doesn't work. Might have something to do with the visibility of symbols? * i'm getting g++ depracated warnings regarding the hash_map from the symbol table, need to figure out how to use it in a standard manner. the new <unordered_map> header is for C++0x, and the <ext/hash_map> is getting deprecation warningns... weird.
Diffstat (limited to 'src/parser/smt/Makefile.am')
-rw-r--r--src/parser/smt/Makefile.am25
1 files changed, 14 insertions, 11 deletions
diff --git a/src/parser/smt/Makefile.am b/src/parser/smt/Makefile.am
index acb95849f..59782de7e 100644
--- a/src/parser/smt/Makefile.am
+++ b/src/parser/smt/Makefile.am
@@ -1,4 +1,4 @@
-INCLUDES = -I@srcdir@/../include -I@srcdir@/..
+INCLUDES = -I@srcdir@/../../include -I@srcdir@/../.. -I@builddir@/../..
AM_CXXFLAGS = -Wall -fvisibility=hidden
AM_CPPFLAGS = -D__BUILDING_CVC4PARSERLIB
@@ -7,19 +7,22 @@ noinst_LTLIBRARIES = libparsersmt.la
libparsersmt_la_SOURCES = \
SmtLexer.g \
SmtParser.g \
- SmtLexer.hpp \
- SmtLexer.cpp \
- SmtParser.hpp \
- SmtParser.cpp
+ AntlrSmtLexer.hpp \
+ AntlrSmtLexer.cpp \
+ AntlrSmtParser.hpp \
+ AntlrSmtParser.cpp
BUILT_SOURCES = \
- SmtLexer.hpp \
- SmtLexer.cpp \
- SmtParser.hpp \
- SmtParser.cpp
+ AntlrSmtLexer.hpp \
+ AntlrSmtLexer.cpp \
+ AntlrSmtParser.hpp \
+ AntlrSmtParser.cpp
-SmtLexer.cpp SmtLexer.hpp: SmtLexer.g
+
+AntlrSmtLexer.hpp: SmtLexer.g
+AntlrSmtLexer.cpp: SmtLexer.g
$(ANTLR) @srcdir@/SmtLexer.g
-SmtParser.cpp SmtParser.hpp: SmtParser.g
+AntlrSmtParser.hpp: SmtParser.g AntlrSmtLexer.cpp
+AntlrSmtParser.cpp: SmtParser.g AntlrSmtLexer.cpp
$(ANTLR) @srcdir@/SmtParser.g
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback