summaryrefslogtreecommitdiff
path: root/src/parser/Makefile.am
diff options
context:
space:
mode:
authorChristopher L. Conway <christopherleeconway@gmail.com>2010-04-28 18:34:11 +0000
committerChristopher L. Conway <christopherleeconway@gmail.com>2010-04-28 18:34:11 +0000
commita72c7a26fda2b9c268912e618fd7d71164e4800a (patch)
treee1694867f049b5328720abc9496cfe926989aae7 /src/parser/Makefile.am
parent7a8454030fdbb1e6c2a6db7ce18eafe0764eaf4a (diff)
Refactoring Input/Parser code to support external manipulation of the parser state.
Diffstat (limited to 'src/parser/Makefile.am')
-rw-r--r--src/parser/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/src/parser/Makefile.am b/src/parser/Makefile.am
index 276266757..1464eeac0 100644
--- a/src/parser/Makefile.am
+++ b/src/parser/Makefile.am
@@ -34,20 +34,17 @@ libcvc4parser_noinst_la_LIBADD = \
libcvc4parser_la_SOURCES =
libcvc4parser_noinst_la_SOURCES = \
- antlr_input.h \
- antlr_input.cpp \
- antlr_input_imports.cpp \
bounded_token_buffer.h \
bounded_token_buffer.cpp \
bounded_token_factory.h \
bounded_token_factory.cpp \
input.h \
input.cpp \
+ input_imports.cpp \
memory_mapped_input_buffer.h \
memory_mapped_input_buffer.cpp \
+ parser.h \
+ parser.cpp \
parser_options.h \
- parser_exception.h \
- parser_state.h \
- parser_state.cpp \
- symbol_table.h
+ parser_exception.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback