summaryrefslogtreecommitdiff
path: root/src/parser/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2011-09-24 18:04:08 +0000
committerMorgan Deters <mdeters@gmail.com>2011-09-24 18:04:08 +0000
commitb79e8b369649f053ce3a39d3d178e4e2dbcf9993 (patch)
tree0d75973130594b7b498cee4dc60b83a267fbad2d /src/parser/Makefile.am
parenta63064385c56600143ac470108fe8e640a4ca3ee (diff)
Fix to building and linking for unit tests. (This should fix the segfaulting units in optimized-dynamic. The problem was that the code incorrectly determined the address of one of the thread-scoped global variables, and I think it's because the same library was linked twice into the unit test in two different ways, confusing the runtime support code.)
Diffstat (limited to 'src/parser/Makefile.am')
-rw-r--r--src/parser/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/parser/Makefile.am b/src/parser/Makefile.am
index d87db20f5..aca11bbd8 100644
--- a/src/parser/Makefile.am
+++ b/src/parser/Makefile.am
@@ -21,7 +21,7 @@ SUBDIRS = smt smt2 cvc
lib_LTLIBRARIES = libcvc4parser.la
if HAVE_CXXTESTGEN
-noinst_LTLIBRARIES = libcvc4parser_noinst.la
+check_LTLIBRARIES = libcvc4parser_noinst.la
endif
libcvc4parser_la_LDFLAGS = $(ANTLR_LDFLAGS) \
@@ -39,7 +39,7 @@ libcvc4parser_noinst_la_LIBADD = \
@builddir@/smt2/libparsersmt2.la \
@builddir@/cvc/libparsercvc.la \
@builddir@/../lib/libreplacements.la \
- -L@builddir@/.. -lcvc4
+ @builddir@/../libcvc4_noinst.la
libcvc4parser_la_SOURCES = \
antlr_input.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback