summaryrefslogtreecommitdiff
path: root/src/parser/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-03-01 14:48:04 +0000
committerMorgan Deters <mdeters@gmail.com>2012-03-01 14:48:04 +0000
commit45a138c326da72890bf889a3670aad503ef4aa1e (patch)
treefa0c9a8497d0b33f78a9f19212152a61392825cc /src/parser/Makefile.am
parent8c0b2d6db32103268f84d89c0d0545c7eb504069 (diff)
Partial merge from kind-backend branch, including Minisat and CNF work to
support incrementality. Some clean-up work will likely follow, but the CNF/Minisat stuff should be left pretty much untouched. Expected performance change negligible; slightly better on memory: http://church.cims.nyu.edu/regress-results/compare_jobs.php?job_id=3705&reference_id=3697&mode=&category=&p=5 Note that there are crashes, but that these are exhibited in the nightly regression run too!
Diffstat (limited to 'src/parser/Makefile.am')
-rw-r--r--src/parser/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/parser/Makefile.am b/src/parser/Makefile.am
index 4f00cfb3d..f14941d01 100644
--- a/src/parser/Makefile.am
+++ b/src/parser/Makefile.am
@@ -45,6 +45,8 @@ libcvc4parser_la_SOURCES = \
antlr_input.h \
antlr_input.cpp \
antlr_input_imports.cpp \
+ antlr_line_buffered_input.h \
+ antlr_line_buffered_input.cpp \
bounded_token_buffer.h \
bounded_token_buffer.cpp \
bounded_token_factory.h \
@@ -64,6 +66,8 @@ libcvc4parser_noinst_la_SOURCES = \
antlr_input.h \
antlr_input.cpp \
antlr_input_imports.cpp \
+ antlr_line_buffered_input.h \
+ antlr_line_buffered_input.cpp \
bounded_token_buffer.h \
bounded_token_buffer.cpp \
bounded_token_factory.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback