summaryrefslogtreecommitdiff
path: root/src/parser/Makefile.am
diff options
context:
space:
mode:
authorDejan Jovanović <dejan.jovanovic@gmail.com>2009-12-06 02:21:46 +0000
committerDejan Jovanović <dejan.jovanovic@gmail.com>2009-12-06 02:21:46 +0000
commitc16be5841e613818d5764e4de99e4694a0703685 (patch)
tree5bf7c07a8f7200c2830d50f5dd83ecbb4f02444d /src/parser/Makefile.am
parent200f36785acf7aac3e7e230795ea7ffdb6b1ed64 (diff)
Big chunk of changes:
* Fixed bugs in option parsing * Simplified the main.cpp significantly (more c++ like) * Added the null kind, expr value, and expression, with the default constructor public * Simplified commands, we need to discuss this in the meeting (what to do with command results?) * Removed all the lex/yacc files * Symbol table is now a templated class, as we will have tables for variables, predicates and functions * The ANTLR parsing infrastructure/makefiles is all in. SMT lib Boolean benchmarks should parse + giving nice error such as Parse Error: /home/dejan/eclipse-cxx/smtlib-parser/test/test4.smt:3:16: Undeclared variable p Parse Error: /home/dejan/eclipse-cxx/smtlib-parser/test/test2.smt:2:11: unexpected token: sa Didn't add any unit tests as the unit testing doesn't work with the updated build system -- it doesn't know how to create directories in the corresponding build directory. TODO: * add the PL grammar and unit test when the testing becomes available * with this build setup my eclipse debugger doesn't work. Might have something to do with the visibility of symbols? * i'm getting g++ depracated warnings regarding the hash_map from the symbol table, need to figure out how to use it in a standard manner. the new <unordered_map> header is for C++0x, and the <ext/hash_map> is getting deprecation warningns... weird.
Diffstat (limited to 'src/parser/Makefile.am')
-rw-r--r--src/parser/Makefile.am58
1 files changed, 9 insertions, 49 deletions
diff --git a/src/parser/Makefile.am b/src/parser/Makefile.am
index 7e3cee751..3c2bfc8ab 100644
--- a/src/parser/Makefile.am
+++ b/src/parser/Makefile.am
@@ -15,62 +15,22 @@
LIBCVC4PARSER_RELEASE = @CVC4_LIBRARY_RELEASE_CODE@
LIBCVC4PARSER_VERSION = @CVC4_PARSER_LIBRARY_VERSION@
-INCLUDES = -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/..
+INCLUDES = -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/.. $(ANTLR_INCLUDES)
AM_CXXFLAGS = -Wall -fvisibility=hidden
AM_CPPFLAGS = -D__BUILDING_CVC4PARSERLIB
-if USE_ANTLR
- SUBDIRS = smt
- INCLUDES += $(ANTLR_INCLUDES)
-endif
+SUBDIRS = smt
-lib_LTLIBRARIES = libcvc4parser.la
-
-libcvc4parser_la_LDFLAGS = -version-info $(LIBCVC4PARSER_VERSION) -release $(LIBCVC4PARSER_RELEASE)
-
-if USE_ANTLR
- libcvc4parser_la_LDFLAGS += $(ANTLR_LDFLAGS)
-endif
+nobase_lib_LTLIBRARIES = libcvc4parser.la
+libcvc4parser_la_LDFLAGS = $(ANTLR_LDFLAGS)
libcvc4parser_la_LIBADD = \
- ../libcvc4.la
+ @builddir@/smt/libparsersmt.la
libcvc4parser_la_SOURCES = \
+ parser.h \
parser.cpp \
- parser_state.cpp \
- symbol_table.cpp \
- pl_scanner.lpp \
- pl.ypp \
- smtlib_scanner.lpp \
- smtlib.ypp
-
-if USE_ANTLR
- libcvc4parser_la_SOURCES += \
- antlr_parser.cpp \
- antlr_parser.h
-endif USE_ANTLR
-
-BUILT_SOURCES = \
- pl_scanner.cpp \
- pl.cpp \
- pl.hpp \
- smtlib_scanner.cpp \
- smtlib.cpp \
- smtlib.hpp
-
-# produce headers too
-AM_YFLAGS = -d
-
-pl_scanner.cpp: pl_scanner.lpp
- $(LEX) $(AM_LFLAGS) $(LFLAGS) -P PL -o $@ $<
-smtlib_scanner.cpp: smtlib_scanner.lpp
- $(LEX) $(AM_LFLAGS) $(LFLAGS) -P smtlib -o $@ $<
-
-pl_scanner.o: pl.hpp
-pl.cpp: pl.ypp
- $(YACC) $(AM_YFLAGS) $(YFLAGS) -p PL -o $@ $<
-
+ symbol_table.h \
+ antlr_parser.h \
+ antlr_parser.cpp
-smtlib_scanner.o: smtlib.hpp
-smtlib.cpp: smtlib.ypp
- $(YACC) $(AM_YFLAGS) $(YFLAGS) -p smtlib -o $@ $<
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback