summaryrefslogtreecommitdiff
path: root/src/parser/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2021-04-19 11:30:04 +0200
committerGitHub <noreply@github.com>2021-04-19 09:30:04 +0000
commita06ec9eb224c437523f3bff0ac6f6437d924f36a (patch)
tree8701141bddf60efe6305f1d1f02fd42ffaeec2d6 /src/parser/CMakeLists.txt
parent353006984c0c7bbd1bd419c04e4bb873c7eee52a (diff)
Remove linking against gmp and cln in tests and parser (#6376)
Finally, we no longer need to link against GMP and CLN for the parser and the tests. To actually achieve this, this PR also removes some dead code and unused includes from some parser files.
Diffstat (limited to 'src/parser/CMakeLists.txt')
-rw-r--r--src/parser/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/parser/CMakeLists.txt b/src/parser/CMakeLists.txt
index 26472740e..da6b1bd58 100644
--- a/src/parser/CMakeLists.txt
+++ b/src/parser/CMakeLists.txt
@@ -108,12 +108,6 @@ target_compile_definitions(cvc4parser PRIVATE -D__BUILDING_CVC4PARSERLIB)
target_link_libraries(cvc4parser PUBLIC cvc4)
target_link_libraries(cvc4parser PRIVATE ANTLR3)
-if(USE_CLN)
- target_link_libraries(cvc4parser PRIVATE ${CLN_LIBRARIES})
- target_include_directories(cvc4parser PRIVATE $<BUILD_INTERFACE:${CLN_INCLUDE_DIR}>)
-endif()
-target_link_libraries(cvc4parser PRIVATE GMP)
-
install(TARGETS cvc4parser
EXPORT cvc4-targets
DESTINATION ${CMAKE_INSTALL_LIBDIR})
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback