summaryrefslogtreecommitdiff
path: root/src/parser/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2019-09-06 15:28:07 -0700
committerGitHub <noreply@github.com>2019-09-06 15:28:07 -0700
commit91a5055015a97935d19b3dbf18062e189268a1f9 (patch)
treefb1fd19d80fb89d71286b462927540c0648d7551 /src/parser/CMakeLists.txt
parent7fc142a10140bba5a732237e3adf8fe6729d90e7 (diff)
Remove SMT1 parser. (#3228)
This commit removes the SMT1 parser infrastructure and adds the SMT2 translations of the SMT1 regression tests. For now this commit removes regression test regress3/pp-regfile.smt since the SMT2 translation has a file size of 887M (vs. 172K for the SMT1 version). Fixes #2948 and fixes #1313.
Diffstat (limited to 'src/parser/CMakeLists.txt')
-rw-r--r--src/parser/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/parser/CMakeLists.txt b/src/parser/CMakeLists.txt
index 96790f834..78ab82cb4 100644
--- a/src/parser/CMakeLists.txt
+++ b/src/parser/CMakeLists.txt
@@ -37,10 +37,6 @@ set(libcvc4parser_src_files
parser_builder.cpp
parser_builder.h
parser_exception.h
- smt1/smt1.cpp
- smt1/smt1.h
- smt1/smt1_input.cpp
- smt1/smt1_input.h
smt2/parse_op.h
smt2/smt2.cpp
smt2/smt2.h
@@ -59,7 +55,7 @@ set(libcvc4parser_src_files
#-----------------------------------------------------------------------------#
# Generate parsers for all supported languages
-foreach(lang Cvc Smt1 Smt2 Tptp)
+foreach(lang Cvc Smt2 Tptp)
string(TOLOWER ${lang} lang_dir)
file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/${lang_dir})
add_custom_command(
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback