summaryrefslogtreecommitdiff
path: root/src/options/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-08-29 11:50:15 +0000
committerMorgan Deters <mdeters@gmail.com>2012-08-29 11:50:15 +0000
commit777d698c0b11c35da05c55488b02b42064c0fc48 (patch)
tree09ba0c53362b695cb1f02b567fdebb1fd8774ae3 /src/options/Makefile.am
parent026c17ed39f34f34d44b676131af64b3c8a4866f (diff)
To the build system:
* Fix "make distclean." This should fix the "local regressions fail" that caused documentation, debian, and "distcheck" nightly build targets to fail. * "make clean" now removes some options stuff that previously required a "make distclean." * Cosmetic and portability adjustments.
Diffstat (limited to 'src/options/Makefile.am')
-rw-r--r--src/options/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/options/Makefile.am b/src/options/Makefile.am
index eb1a2c498..f89fca922 100644
--- a/src/options/Makefile.am
+++ b/src/options/Makefile.am
@@ -101,7 +101,7 @@ BUILT_SOURCES = \
options.cpp \
options_holder.h
-DISTCLEANFILES = \
+CLEANFILES = \
$(OPTIONS_FILES_SRCS) \
$(BUILT_SOURCES) \
options-stamp
@@ -178,11 +178,17 @@ options-stamp: options_holder_template.h options_template.cpp ../smt/smt_options
@top_builddir@/doc/cvc4.1_template @top_builddir@/doc/cvc4.1 \
-t \
@srcdir@/base_options_template.h @srcdir@/base_options_template.cpp \
- $(foreach o,$(OPTIONS_FILES),"$(srcdir)/$(o)" "$(dir $(builddir)/$(o))") \
+ $(foreach o,$(OPTIONS_FILES),"$(srcdir)/$(o)" "$(patsubst %/,%,$(dir $(o)))") \
)
touch "$@"
$(OPTIONS_FILES):;
+# This rule is ugly. It's needed to ensure that automake's dependence
+# includes are available during distclean, even though they come from
+# directories that are cleaned first. Without this rule, "distclean"
+# fails.
+%.Plo:; $(MKDIR_P) "$(dir $@)" && : > "$@"
+
.PHONY: exprs-builts
exprs-builts:; $(AM_V_at)[ "$(FROM_EXPR)" != 1 ] && $(MAKE) -C ../expr builts || true
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback