summaryrefslogtreecommitdiff
path: root/src/options/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <nafur42@gmail.com>2021-08-06 11:55:18 -0700
committerGitHub <noreply@github.com>2021-08-06 18:55:18 +0000
commitc8bc4881d4f3bf54258b0f01280fbda23a1dd651 (patch)
tree7212c1a3c0b98589a0e15f6f32b86523a09fa540 /src/options/CMakeLists.txt
parente04248ec858c97b8d716796f87ed42078a953967 (diff)
Merge options cmake into general cmake file (#6989)
This PR removes options/CMakeLists.txt and merges its contents into src/CMakeLists.txt and does some generalization in the mkoptions.py script. This prepares the whole setup so that we can also generate options code in other directories than options/ easily in the future: parts of the options code will be moved to the main folder.
Diffstat (limited to 'src/options/CMakeLists.txt')
-rw-r--r--src/options/CMakeLists.txt111
1 files changed, 0 insertions, 111 deletions
diff --git a/src/options/CMakeLists.txt b/src/options/CMakeLists.txt
deleted file mode 100644
index a75806504..000000000
--- a/src/options/CMakeLists.txt
+++ /dev/null
@@ -1,111 +0,0 @@
-###############################################################################
-# Top contributors (to current version):
-# Mathias Preiner, Aina Niemetz, Andrew Reynolds
-#
-# This file is part of the cvc5 project.
-#
-# Copyright (c) 2009-2021 by the authors listed in the file AUTHORS
-# in the top-level source directory and their institutional affiliations.
-# All rights reserved. See the file COPYING in the top-level source
-# directory for licensing information.
-# #############################################################################
-#
-# The build system configuration.
-##
-
-# Check if the toml Python module is installed.
-check_python_module("toml")
-
-libcvc5_add_sources(
- decision_weight.h
- didyoumean.cpp
- didyoumean.h
- language.cpp
- language.h
- managed_streams.cpp
- managed_streams.h
- option_exception.cpp
- option_exception.h
- options_handler.cpp
- options_handler.h
- options_listener.h
- options_public.h
- outputc.cpp
- outputc.h
- printer_modes.cpp
- printer_modes.h
- set_language.cpp
- set_language.h
-)
-
-set(options_toml_files
- arith_options.toml
- arrays_options.toml
- base_options.toml
- booleans_options.toml
- builtin_options.toml
- bv_options.toml
- datatypes_options.toml
- decision_options.toml
- expr_options.toml
- fp_options.toml
- main_options.toml
- parser_options.toml
- printer_options.toml
- proof_options.toml
- prop_options.toml
- quantifiers_options.toml
- sep_options.toml
- sets_options.toml
- smt_options.toml
- strings_options.toml
- theory_options.toml
- uf_options.toml
-)
-
-string(REPLACE "toml" "cpp;" options_gen_cpp_files ${options_toml_files})
-string(REPLACE "toml" "h;" options_gen_h_files ${options_toml_files})
-
-libcvc5_add_sources(GENERATED options.h options.cpp options_public.cpp ${options_gen_cpp_files})
-
-list_prepend(options_toml_files "${CMAKE_CURRENT_LIST_DIR}/" abs_toml_files)
-
-set(options_gen_doc_files "")
-if (BUILD_DOCS)
- list(
- APPEND
- options_gen_doc_files
- "${CMAKE_BINARY_DIR}/docs/options_generated.rst"
- )
-endif()
-
-add_custom_command(
- OUTPUT
- options.h options.cpp options_public.cpp
- ${options_gen_cpp_files} ${options_gen_h_files}
- ${options_gen_doc_files}
- COMMAND
- ${PYTHON_EXECUTABLE}
- ${CMAKE_CURRENT_LIST_DIR}/mkoptions.py
- ${CMAKE_CURRENT_LIST_DIR}
- ${CMAKE_BINARY_DIR}
- ${CMAKE_CURRENT_BINARY_DIR}
- ${abs_toml_files}
- DEPENDS
- mkoptions.py
- ${options_toml_files}
- module_template.h
- module_template.cpp
- options_public_template.cpp
- options_template.h
- options_template.cpp
-)
-
-add_custom_target(gen-options
- DEPENDS
- options.h
- options.cpp
- options_public.cpp
- ${options_gen_cpp_files}
- ${options_gen_h_files}
-)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback