summaryrefslogtreecommitdiff
path: root/src/main/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-02-22 06:54:19 +0000
committerMorgan Deters <mdeters@gmail.com>2010-02-22 06:54:19 +0000
commit69d6fcbf56ed823461189f2488e5c2b2f44dca02 (patch)
tree9074ffd26dd0201f914985df69d4643e455eacbf /src/main/Makefile.am
parent65fa7fd4d674e00624657255c24748e580ef50d6 (diff)
fix bug 33 (statically link the "cvc4" binary); also main driver cleanup
Diffstat (limited to 'src/main/Makefile.am')
-rw-r--r--src/main/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/main/Makefile.am b/src/main/Makefile.am
index 04d717294..79eb8c74e 100644
--- a/src/main/Makefile.am
+++ b/src/main/Makefile.am
@@ -15,4 +15,8 @@ cvc4_LDADD = \
../parser/libcvc4parser.la \
../libcvc4.la
+if STATIC_BINARY
+cvc4_LINK = $(CXXLINK) -all-static
+else
cvc4_LINK = $(CXXLINK)
+endif
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback