summaryrefslogtreecommitdiff
path: root/src/main/Makefile.am
diff options
context:
space:
mode:
authorChristopher L. Conway <christopherleeconway@gmail.com>2010-10-24 16:37:00 +0000
committerChristopher L. Conway <christopherleeconway@gmail.com>2010-10-24 16:37:00 +0000
commitade732181ad2eabfb3a6eef46bdc9ea42d27246e (patch)
treed487a25c2cc7bfbf610b57e9b4cd5cba2701a4c4 /src/main/Makefile.am
parentd8a8f335f4043a0117f2b92af3d1e94f285e4d30 (diff)
Adding unit test for InteractiveShell
Diffstat (limited to 'src/main/Makefile.am')
-rw-r--r--src/main/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/main/Makefile.am b/src/main/Makefile.am
index 05a451d52..52a659322 100644
--- a/src/main/Makefile.am
+++ b/src/main/Makefile.am
@@ -4,8 +4,9 @@ AM_CPPFLAGS = \
AM_CXXFLAGS = -Wall -Wno-unknown-pragmas
bin_PROGRAMS = cvc4
+noinst_LIBRARIES = libmain.a
-cvc4_SOURCES = \
+libmain_a_SOURCES = \
interactive_shell.h \
interactive_shell.cpp \
main.h \
@@ -13,10 +14,12 @@ cvc4_SOURCES = \
usage.h \
util.cpp
+cvc4_SOURCES =
cvc4_LDADD = \
../parser/libcvc4parser.la \
../libcvc4.la \
- ../lib/libreplacements.la
+ ../lib/libreplacements.la \
+ libmain.a
if STATIC_BINARY
cvc4_LINK = $(CXXLINK) -all-static
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback