summaryrefslogtreecommitdiff
path: root/src/main/Makefile.am
diff options
context:
space:
mode:
authorKshitij Bansal <kshitij@cs.nyu.edu>2012-09-08 14:25:25 +0000
committerKshitij Bansal <kshitij@cs.nyu.edu>2012-09-08 14:25:25 +0000
commitcfa9e2cbbdf77a325791b5548b41093a0781311c (patch)
treee843d38afe4b197a2dd81316998477cedac26c52 /src/main/Makefile.am
parent6935324f45bd7f2c735ca4120a9e800ef8903442 (diff)
Single driver for both sequential and portfolio
A "command executer" layer between parsing commands and invoking them. New implementation of portfolio driver splits only when check-sat or query command is encountered, and then switches back to sequential till the next one. As side effect, restores functionality of interactive mode and push/pops.
Diffstat (limited to 'src/main/Makefile.am')
-rw-r--r--src/main/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/main/Makefile.am b/src/main/Makefile.am
index c1291e7ec..9b0200231 100644
--- a/src/main/Makefile.am
+++ b/src/main/Makefile.am
@@ -19,14 +19,17 @@ pcvc4_SOURCES = \
main.cpp \
portfolio.cpp \
portfolio.h \
- driver_portfolio.cpp
+ portfolio_util.cpp \
+ command_executer.cpp \
+ command_executer_portfolio.cpp \
+ driver_unified.cpp
pcvc4_LDADD = \
libmain.a \
@builddir@/../parser/libcvc4parser.la \
@builddir@/../libcvc4.la \
@builddir@/../lib/libreplacements.la \
$(READLINE_LIBS)
-pcvc4_CPPFLAGS = $(AM_CPPFLAGS) $(BOOST_CPPFLAGS)
+pcvc4_CPPFLAGS = $(AM_CPPFLAGS) $(BOOST_CPPFLAGS) -DPORTFOLIO_BUILD
pcvc4_LDADD += $(BOOST_THREAD_LIBS) -lpthread
pcvc4_LDADD += $(BOOST_THREAD_LDFLAGS)
@@ -39,7 +42,8 @@ endif
cvc4_SOURCES = \
main.cpp \
- driver.cpp
+ command_executer.cpp \
+ driver_unified.cpp
cvc4_LDADD = \
libmain.a \
@builddir@/../parser/libcvc4parser.la \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback