summaryrefslogtreecommitdiff
path: root/src/main/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-08-16 18:07:59 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commite8471288c0062d9e887d559a7c6f934bc85ea5ba (patch)
tree5ca73eb50f2dcd7422044ab39e30b3cc320bcba4 /src/main/CMakeLists.txt
parent385b9961186691c0618754bc9b0f49458c20445d (diff)
cmake: Do not set global output directories for binaries and libraries.
Diffstat (limited to 'src/main/CMakeLists.txt')
-rw-r--r--src/main/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/main/CMakeLists.txt b/src/main/CMakeLists.txt
index 7ac8b1194..b49a28223 100644
--- a/src/main/CMakeLists.txt
+++ b/src/main/CMakeLists.txt
@@ -21,7 +21,10 @@ set(cvc4main_src_files
add_executable(cvc4-main ${cvc4main_src_files})
target_compile_definitions(cvc4-main PRIVATE -D__BUILDING_CVC4DRIVER)
-set_target_properties(cvc4-main PROPERTIES OUTPUT_NAME cvc4)
+set_target_properties(cvc4-main
+ PROPERTIES
+ OUTPUT_NAME cvc4
+ RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
target_link_libraries(cvc4-main main)
add_dependencies(cvc4-main token-headers)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback