summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2011-09-02 20:41:08 +0000
committerMorgan Deters <mdeters@gmail.com>2011-09-02 20:41:08 +0000
commit1d18e5ebed9a5b20ed6a8fe21d11842acf6fa7ea (patch)
tree7074f04453914bc377ff6aeb307dd17b82b76ff3 /src/expr/Makefile.am
parent74770f1071e6102795393cf65dd0c651038db6b4 (diff)
Merge from my post-smtcomp branch. Includes:
Dumping infrastructure. Can dump preprocessed queries and clauses. Can also dump queries (for testing with another solver) to see if any conflicts are missed, T-propagations are missed, all lemmas are T-valid, etc. For a full list of options see --dump=help. CUDD building much cleaner. Documentation and assertion fixes. Printer improvements, printing of commands in language-defined way, etc. Typechecker stuff in expr package now autogenerated, no need to manually edit the expr package when adding a new theory. CVC3 compatibility layer (builds as libcompat). SWIG detection and language binding support (infrastructure). Support for some Z3 extended commands (like datatypes) in SMT-LIBv2 mode (when not in compliance mode). Copyright and file headers regenerated.
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index 352647642..738604f90 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -16,6 +16,7 @@ libexpr_la_SOURCES = \
type.cpp \
node_value.h \
node_manager.h \
+ type_checker.h \
attribute.h \
attribute_internals.h \
attribute.cpp \
@@ -37,7 +38,8 @@ nodist_libexpr_la_SOURCES = \
expr.h \
expr.cpp \
expr_manager.h \
- expr_manager.cpp
+ expr_manager.cpp \
+ type_checker.cpp
EXTRA_DIST = \
kind_template.h \
@@ -47,6 +49,7 @@ EXTRA_DIST = \
expr_manager_template.cpp \
expr_template.h \
expr_template.cpp \
+ type_checker_template.cpp \
mkkind \
mkmetakind \
mkexpr
@@ -59,6 +62,7 @@ BUILT_SOURCES = \
expr.cpp \
expr_manager.h \
expr_manager.cpp \
+ type_checker.cpp \
$(top_builddir)/src/theory/.subdirs
CLEANFILES = \
@@ -68,6 +72,7 @@ CLEANFILES = \
expr.cpp \
expr_manager.h \
expr_manager.cpp \
+ type_checker.cpp \
$(top_builddir)/src/theory/.subdirs
include @top_srcdir@/src/theory/Makefile.subdirs
@@ -127,3 +132,11 @@ expr_manager.cpp: expr_manager_template.cpp mkexpr @top_builddir@/src/theory/.su
$< \
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
+
+type_checker.cpp: type_checker_template.cpp mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+ $(AM_V_at)chmod +x @srcdir@/mkexpr
+ $(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
+ $(AM_V_GEN)(@srcdir@/mkexpr \
+ $< \
+ `cat @top_builddir@/src/theory/.subdirs` \
+ > $@) || (rm -f $@ && exit 1)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback