summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-03-08 23:49:47 +0000
committerMorgan Deters <mdeters@gmail.com>2010-03-08 23:49:47 +0000
commitcf4d347cbbbb4c1a1e1db99337cfd2b22b84b756 (patch)
treeceea43e3d37525038bed10b115c73a8aa08ce68d /src/expr/Makefile.am
parentde0160112edbed8ce9b62bf87172ae2f0e99a013 (diff)
This fixes regressions at levels >= 1 which were failing
* implement zombification and garbage collection of NodeValues (but GC not turned on yet) * implement removal of key nodes from all attribute tables * audit NodeBuilder and fix memory leaks and improper reference-count management. This is in many places a re-write. Clearly documented invariants on NodeBuilder state. (Closes Bug 38) * created a "BackedNodeBuilder" that can be used to construct NodeBuilders with a stack-based backing store for a size that's not a compile-time constant. * NodeValues no longer depend on Node for toStream()'ing * make unit test-building "silent" with --enable-silent-rules * (Makefile.am, Makefile.builds.in) fix top-level build system so that "make regressN" works with unbuilt/out-of-date source trees in the expected way. * (various) code cleanup, documentation, formatting
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index bd02cf452..3deed9a52 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -15,6 +15,7 @@ libexpr_la_SOURCES = \
node_manager.h \
expr_manager.h \
attribute.h \
+ attribute.cpp \
@srcdir@/kind.h \
node_builder.cpp \
node_manager.cpp \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback