summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-02-19 20:29:58 +0000
committerMorgan Deters <mdeters@gmail.com>2010-02-19 20:29:58 +0000
commitce0e796ad92f040fb75435bd7880bc28a60b0374 (patch)
tree00a390f0347a30978b482cbbb6e074c6dc5a99d2 /src/expr/Makefile.am
parent34b455b1d74fdc06dd2f874fa2bc8d73127fbedf (diff)
* Attribute infrastructure -- static design. Documentation is coming.
See test/unit/expr/node_white.h for use examples, including how to define new attribute kinds. Also: * fixes to test infrastructure * minor changes to code formatting throughout * attribute tests in test/unit/expr/node_white.h * fixes to NodeManagerScope ordering * use NodeValue::getKind() to properly deal with UNDEFINED_KIND (removing compiler warning) * ExprManager: add proper NodeManagerScope to public-facing member functions * store variable names and types in attributes * SoftNode is a placeholder, not a real implementation
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index dd5b2a2f6..7393f27a5 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -6,8 +6,6 @@ AM_CXXFLAGS = -Wall -fvisibility=hidden
noinst_LTLIBRARIES = libexpr.la
libexpr_la_SOURCES = \
- attr_type.h \
- attr_var_name.h \
node.h \
node_builder.h \
expr.h \
@@ -15,7 +13,8 @@ libexpr_la_SOURCES = \
node_value.h \
node_manager.h \
expr_manager.h \
- node_attribute.h \
+ attribute.h \
+ attribute.cpp \
@srcdir@/kind.h \
node.cpp \
node_builder.cpp \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback