summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
authorDejan Jovanović <dejan.jovanovic@gmail.com>2010-04-26 21:37:34 +0000
committerDejan Jovanović <dejan.jovanovic@gmail.com>2010-04-26 21:37:34 +0000
commit3ee48833fd8cffe897a05a986c08a30d9de57213 (patch)
treedb56dd28b96b12414a763ee9104adc8389225ca5 /src/expr/Makefile.am
parent96733823eadf9ff566a177cf74e19d1712c48e4b (diff)
Adding the intermediary TypeNode to represent (and separate) the Types at the Node level.
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index 0abeebb9e..404334199 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -8,9 +8,12 @@ noinst_LTLIBRARIES = libexpr.la
libexpr_la_SOURCES = \
node.h \
node.cpp \
+ type_node.h \
+ type_node.cpp \
node_builder.h \
@srcdir@/expr.h \
type.h \
+ type.cpp \
node_value.h \
node_manager.h \
@srcdir@/expr_manager.h \
@@ -22,7 +25,6 @@ libexpr_la_SOURCES = \
@srcdir@/expr_manager.cpp \
node_value.cpp \
@srcdir@/expr.cpp \
- type.cpp \
command.h \
command.cpp \
declaration_scope.h \
@@ -36,6 +38,8 @@ EXTRA_DIST = \
@srcdir@/expr.h \
@srcdir@/expr_manager.cpp \
@srcdir@/expr.cpp \
+ @srcdir@/type.h \
+ @srcdir@/type.cpp \
kind_template.h \
metakind_template.h \
expr_manager_template.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback