summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-02-25 18:26:22 +0000
committerMorgan Deters <mdeters@gmail.com>2010-02-25 18:26:22 +0000
commit374e28dcc625f1694cfc87f7b4c376dc329694c4 (patch)
tree0f65baaf336a8033617dd2c1cdaa1ffccc10d3f7 /src/expr/Makefile.am
parent826f583ee14b922f39666dc827a5624fff753724 (diff)
* src/expr/node_builder.h: fixed some overly-aggressive refcount decrementing.
There remain memory leaks (and some over-decrementing of refcounts) that I've identified; another commit forthcoming. * src/expr/attribute.h: keys are now NodeValue* instead of TNode * src/theory/output_channel.h: change OutputChannel::conflict() to the negation of what we had before: it now takes an AND of TRUE literals as a conflict clause rather than an OR of FALSE ones. * src/expr/node.cpp: (non-template) CVC4::expr::debugPrint() routine for use inside gdb * src/expr/node.h: remove Node::debugPrint() member (now a function instead of a member function, since Node is now a template it wasn't being properly instantiated(?) and couldn't be called from gdb) * src/expr/Makefile.am: add node.cpp * src/expr/node_manager.h: code formatting
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index 27c64e9ef..1aa2e61fa 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -7,6 +7,7 @@ noinst_LTLIBRARIES = libexpr.la
libexpr_la_SOURCES = \
node.h \
+ node.cpp \
node_builder.h \
expr.h \
type.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback