summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2017-08-14 20:10:55 -0700
committerGitHub <noreply@github.com>2017-08-14 20:10:55 -0700
commit779ca55f2802b2c77ea39d1c94a097a9761f544c (patch)
tree62df53e6e889cfde7ec8691006a068c3c23b6dfa /src/expr/Makefile.am
parentc577a90f58374e64d293fe02293dc31c693704ef (diff)
Move function definitions from metakind.h to cpp (#218)
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index 06a252b3c..bf4ad9acd 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -69,6 +69,7 @@ nodist_libexpr_la_SOURCES = \
kind.h \
kind.cpp \
metakind.h \
+ metakind.cpp \
type_properties.h \
expr.h \
expr.cpp \
@@ -86,6 +87,7 @@ EXTRA_DIST = \
kind_template.h \
kind_template.cpp \
metakind_template.h \
+ metakind_template.cpp \
type_properties_template.h \
expr_manager_template.h \
expr_manager_template.cpp \
@@ -109,6 +111,7 @@ BUILT_SOURCES = \
kind.h \
kind.cpp \
metakind.h \
+ metakind.cpp \
type_properties.h \
expr.h \
expr.cpp \
@@ -121,6 +124,7 @@ CLEANFILES = \
kind.h \
kind.cpp \
metakind.h \
+ metakind.cpp \
expr.h \
expr.cpp \
expr_manager.h \
@@ -162,6 +166,14 @@ metakind.h: metakind_template.h mkmetakind @top_builddir@/src/expr/.subdirs $(if
`cat @top_builddir@/src/expr/.subdirs` \
> $@) || (rm -f $@ && exit 1)
+metakind.cpp: metakind_template.cpp mkmetakind @top_builddir@/src/expr/.subdirs $(if $(COVERAGE_ON), @abs_top_srcdir@, @top_srcdir@)/src/theory/*/kinds
+ $(AM_V_at)chmod +x @srcdir@/mkmetakind
+ $(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
+ $(AM_V_GEN)(@srcdir@/mkmetakind \
+ $< \
+ `cat @top_builddir@/src/expr/.subdirs` \
+ > $@) || (rm -f $@ && exit 1)
+
type_properties.h: type_properties_template.h mkkind @top_builddir@/src/expr/.subdirs $(if $(COVERAGE_ON), @abs_top_srcdir@, @top_srcdir@)/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mkkind
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback