summaryrefslogtreecommitdiff
path: root/src/expr/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Ozdemir <aozdemir@hmc.edu>2020-03-27 23:22:41 -0700
committerGitHub <noreply@github.com>2020-03-27 23:22:41 -0700
commit9023d348d0f30fdd81805f224e77e90ecef1350d (patch)
treea8929284b8ab84328bee436a16065c2ba54e02cb /src/expr/CMakeLists.txt
parent8ee4da5904e15c7900109a82ec126ce87715e548 (diff)
Node traversal iterator (#3845)
Implement an iterator for pre- and post-order traversals. I believe that this will be useful in pre-processing passes, many of which do postorder traversals that they implement by hand. Right now this iterator does not support modification of the traversal pattern, but we could add this later on, if we want it. Co-authored-by: Andres Noetzli <andres.noetzli@gmail.com> Co-authored-by: Mathias Preiner <mathias.preiner@gmail.com>
Diffstat (limited to 'src/expr/CMakeLists.txt')
-rw-r--r--src/expr/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/expr/CMakeLists.txt b/src/expr/CMakeLists.txt
index d1faa8ffb..00bd121cb 100644
--- a/src/expr/CMakeLists.txt
+++ b/src/expr/CMakeLists.txt
@@ -29,6 +29,8 @@ libcvc4_add_sources(
node_self_iterator.h
node_trie.cpp
node_trie.h
+ node_traversal.cpp
+ node_traversal.h
node_value.cpp
node_value.h
node_visitor.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback