summaryrefslogtreecommitdiff
path: root/src/expr/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-04-15 17:09:40 -0500
committerGitHub <noreply@github.com>2020-04-15 17:09:40 -0500
commit912b65006615fe4074cde54b080f48e3d6c12042 (patch)
tree99b1d0ad565ac79d7ebaaa305a42d5052d06b206 /src/expr/CMakeLists.txt
parenteacb636406e609299b6e5b64e93f1cf5b73f4ba3 (diff)
Add ProofNode data structure (#4311)
This is the core data structure for proofs in the new proofs infrastructure. PfRule is a global enumeration of ids of proof nodes (analogous to Kind for Nodes).
Diffstat (limited to 'src/expr/CMakeLists.txt')
-rw-r--r--src/expr/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/expr/CMakeLists.txt b/src/expr/CMakeLists.txt
index a308e536c..aa928fdb7 100644
--- a/src/expr/CMakeLists.txt
+++ b/src/expr/CMakeLists.txt
@@ -33,6 +33,10 @@ libcvc4_add_sources(
node_value.cpp
node_value.h
node_visitor.h
+ proof_node.cpp
+ proof_node.h
+ proof_rule.cpp
+ proof_rule.h
symbol_table.cpp
symbol_table.h
term_canonize.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback