summaryrefslogtreecommitdiff
path: root/src/context/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2010-09-27 21:10:47 +0000
committerTim King <taking@cs.nyu.edu>2010-09-27 21:10:47 +0000
commit595751a1814cc9375318c9c158caf6426eeda791 (patch)
tree91cd27f6f3de253cea4c8350307d0c8a0ee5383e /src/context/Makefile.am
parent6e59b60947283d864877c2c2dc883e878913a2d8 (diff)
- This update adds DynamicArray<T>. This is a bare bones heap allocated array that dynamically can increase in size. This has functionality similar to vector<T>. The main difference is that it can be constructed in an ill-formed manner. This means that it can generalize CDList<T>.
- CDVector<T> has been added. This is intended to allow for context-dependent destructive updates, while the vector size increases are permanent. Behaviorally, this is most similar to vector< CDO<T> >. The differences between the two are: only one ContextObj is registered to the Context, backtracks are done in a lazy fashion, CDVector::push_back(val) sets the value of back() at context level 0 to val where vector<CDO<T>>::push_back(val) sets back() at the current context level to val and back() at context level 0 to the default constructor T().
Diffstat (limited to 'src/context/Makefile.am')
-rw-r--r--src/context/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/context/Makefile.am b/src/context/Makefile.am
index 7a40bab1b..398de65a3 100644
--- a/src/context/Makefile.am
+++ b/src/context/Makefile.am
@@ -13,4 +13,5 @@ libcontext_la_SOURCES = \
cdo.h \
cdlist.h \
cdmap.h \
- cdset.h
+ cdset.h \
+ cdvector.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback