summaryrefslogtreecommitdiff
path: root/src/context/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2021-04-15 14:45:54 -0700
committerGitHub <noreply@github.com>2021-04-15 21:45:54 +0000
commit640a07690826d4bbd87398949091b94b32e35c7a (patch)
tree6977ce7ed5f55b77f3ca79e055c411a3fa09b3fe /src/context/CMakeLists.txt
parent3564c3345d7fa53744661d815cbd463cc02567d7 (diff)
Build support library from base and context. (#6368)
This PR creates a support library from the utilities in base and context, which will be required in the parser as soon as we move the symbol table/manager to the parser. Note: I decided to always build static libraries from base and context (and optionally enable -fPIC for shared builds) since I'm not sure if we want to have these libraries installed separately. Right now these are considered as cvc5 internal utilities that can be used in all cvc5 libraries, but not outside.
Diffstat (limited to 'src/context/CMakeLists.txt')
-rw-r--r--src/context/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/context/CMakeLists.txt b/src/context/CMakeLists.txt
new file mode 100644
index 000000000..8800f1a23
--- /dev/null
+++ b/src/context/CMakeLists.txt
@@ -0,0 +1,41 @@
+###############################################################################
+# Top contributors (to current version):
+# Mathias Preiner, Aina Niemetz, Gereon Kremer
+#
+# This file is part of the cvc5 project.
+#
+# Copyright (c) 2009-2021 by the authors listed in the file AUTHORS
+# in the top-level source directory and their institutional affiliations.
+# All rights reserved. See the file COPYING in the top-level source
+# directory for licensing information.
+# #############################################################################
+#
+# The build system configuration.
+##
+
+set(LIBCONTEXT_SOURCES
+ backtrackable.h
+ cddense_set.h
+ cdhashmap.h
+ cdhashmap_forward.h
+ cdhashset.h
+ cdhashset_forward.h
+ cdinsert_hashmap.h
+ cdinsert_hashmap_forward.h
+ cdlist.h
+ cdlist_forward.h
+ cdmaybe.h
+ cdo.h
+ cdqueue.h
+ cdtrail_queue.h
+ context.cpp
+ context.h
+ context_mm.cpp
+ context_mm.h
+)
+
+add_library(cvc4context STATIC ${LIBCONTEXT_SOURCES})
+if(ENABLE_SHARED)
+ set_target_properties(cvc4context PROPERTIES POSITION_INDEPENDENT_CODE ON)
+endif()
+target_compile_definitions(cvc4context PRIVATE -D__BUILDING_CVC4LIB)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback