summaryrefslogtreecommitdiff
path: root/src/bindings/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-11-12 18:34:32 +0000
committerMorgan Deters <mdeters@gmail.com>2012-11-12 18:34:32 +0000
commit1c2c416b953309279c43c86a46b5690642ff95dd (patch)
tree3cee55cb762199ca28aeceaa589431c064459748 /src/bindings/Makefile.am
parent0ba075e240b2083163ab35a3580547cae6927b6c (diff)
* Fix language bindings: various issues
** remove a number of warnings in bindings generation ** give appropriate names for operator-overloading ** make sure Java language bindings are built with -fno-strict-aliasing, to ensure the optimizer doesn't produce bad code * Also remove BitVector::equals(), which wasn't used and was inconsistently implemented (operator==() is still there). (this commit was certified error- and warning-free by the test-and-commit script.)
Diffstat (limited to 'src/bindings/Makefile.am')
-rw-r--r--src/bindings/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/bindings/Makefile.am b/src/bindings/Makefile.am
index 68a65b2c9..a747a3812 100644
--- a/src/bindings/Makefile.am
+++ b/src/bindings/Makefile.am
@@ -141,7 +141,7 @@ endif
endif
nodist_java_libcvc4jni_la_SOURCES = java.cpp
-java_libcvc4jni_la_CXXFLAGS = -fno-strict-aliasing
+java_libcvc4jni_la_CXXFLAGS = @FNO_STRICT_ALIASING@ @WNO_UNUSED_VARIABLE@ @WNO_UNINITIALIZED@
nodist_csharp_CVC4_la_SOURCES = csharp.cpp
nodist_perl_CVC4_la_SOURCES = perl.cpp
nodist_php_CVC4_la_SOURCES = php.cpp
@@ -168,7 +168,7 @@ MOSTLYCLEANFILES = \
CVC4.jar
java_libcvc4jni_la-java.lo java.lo: java.cpp
- $(AM_V_CXX)$(LTCXXCOMPILE) -c $(JAVA_CPPFLAGS) -o $@ $<
+ $(AM_V_CXX)$(LTCXXCOMPILE) -c $(JAVA_CPPFLAGS) $(java_libcvc4jni_la_CXXFLAGS) -o $@ $<
CVC4.jar: java.cpp
$(AM_V_GEN) \
(cd java; \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback