summaryrefslogtreecommitdiff
path: root/src/base/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@google.com>2016-11-06 22:27:00 -0800
committerTim King <taking@google.com>2016-11-06 22:27:00 -0800
commitb92880a5cfb374f4650052ba93919f473075926a (patch)
treebc3ea5bceac2be29de3c3155c00bce8968fd7c91 /src/base/Makefile.am
parent7fa16f98bbc1cdfa450c55086dc093a9963b63d5 (diff)
Adds a C++05 version of unique_ptr. Used this to solve a garbage collection problem caused by memory leaks of heap allocated Parsers.
Diffstat (limited to 'src/base/Makefile.am')
-rw-r--r--src/base/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/base/Makefile.am b/src/base/Makefile.am
index bda063176..94e45c542 100644
--- a/src/base/Makefile.am
+++ b/src/base/Makefile.am
@@ -20,6 +20,7 @@ libbase_la_SOURCES = \
configuration_private.h \
cvc4_assert.cpp \
cvc4_assert.h \
+ cvc4_unique_ptr.h \
exception.cpp \
exception.h \
listener.cpp \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback