summaryrefslogtreecommitdiff
path: root/src/api/python/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <nafur42@gmail.com>2021-09-30 12:15:24 -0700
committerGitHub <noreply@github.com>2021-09-30 19:15:24 +0000
commit65e5a909b10855d2e6b3844f7bc4efb7fbe4fe2f (patch)
treebb541a32e3985be59ffdc323038677bbace24ede /src/api/python/CMakeLists.txt
parent5a824c9e67789a529e34b7e2a7229986412bf979 (diff)
Refactor our static builds (#7251)
This PR does a major refactoring on how we organize our builds to allow both shared and static builds. We now build the libraries using object libraries to allow building the libraries both dynamically and statically in the same build folder, though the static library is optional (ENABLE_STATIC_LIBRARY). The binary is linked either dynamically or statically (depending on ENABLE_STATIC_BINARY).
Diffstat (limited to 'src/api/python/CMakeLists.txt')
-rw-r--r--src/api/python/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/api/python/CMakeLists.txt b/src/api/python/CMakeLists.txt
index 7ee559a6a..dce0208cb 100644
--- a/src/api/python/CMakeLists.txt
+++ b/src/api/python/CMakeLists.txt
@@ -92,7 +92,7 @@ target_include_directories(pycvc5
${CMAKE_BINARY_DIR}/src # for cvc5_export.h
)
-target_link_libraries(pycvc5 cvc5)
+target_link_libraries(pycvc5 cvc5-shared)
# Disable -Werror and other warnings for code generated by Cython.
# Note: Visibility is reset to default here since otherwise the PyInit_...
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback