summaryrefslogtreecommitdiff
path: root/src/api/java/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <nafur42@gmail.com>2021-09-30 12:15:24 -0700
committerGitHub <noreply@github.com>2021-09-30 19:15:24 +0000
commit65e5a909b10855d2e6b3844f7bc4efb7fbe4fe2f (patch)
treebb541a32e3985be59ffdc323038677bbace24ede /src/api/java/CMakeLists.txt
parent5a824c9e67789a529e34b7e2a7229986412bf979 (diff)
Refactor our static builds (#7251)
This PR does a major refactoring on how we organize our builds to allow both shared and static builds. We now build the libraries using object libraries to allow building the libraries both dynamically and statically in the same build folder, though the static library is optional (ENABLE_STATIC_LIBRARY). The binary is linked either dynamically or statically (depending on ENABLE_STATIC_BINARY).
Diffstat (limited to 'src/api/java/CMakeLists.txt')
-rw-r--r--src/api/java/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/api/java/CMakeLists.txt b/src/api/java/CMakeLists.txt
index 69605c06a..a2fc1dba9 100644
--- a/src/api/java/CMakeLists.txt
+++ b/src/api/java/CMakeLists.txt
@@ -127,7 +127,7 @@ target_include_directories(cvc5jni PUBLIC ${PROJECT_SOURCE_DIR}/src)
target_include_directories(cvc5jni PUBLIC ${CMAKE_BINARY_DIR}/src/)
target_include_directories(cvc5jni PUBLIC ${JNI_DIR})
target_link_libraries(cvc5jni PRIVATE ${JNI_LIBRARIES})
-target_link_libraries(cvc5jni PRIVATE cvc5)
+target_link_libraries(cvc5jni PRIVATE cvc5-shared)
set(CVC5_JAR "cvc5-${CVC5_MAJOR}.${CVC5_MINOR}.${CVC5_RELEASE}.jar")
@@ -139,4 +139,4 @@ add_jar(cvc5jar
OUTPUT_NAME cvc5
)
-add_dependencies(cvc5jar generate-java-kinds cvc5jni cvc5)
+add_dependencies(cvc5jar generate-java-kinds cvc5jni cvc5-shared)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback