summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChristopher L. Conway <christopherleeconway@gmail.com>2009-12-17 19:04:45 +0000
committerChristopher L. Conway <christopherleeconway@gmail.com>2009-12-17 19:04:45 +0000
commitd4e7b9cce6947498738bd3cfb67c11e3bf6c8dbe (patch)
treed3e403fec6d98c2b32cab442d8a9ff853b8a6c2e /src/Makefile.am
parent7eb18a6c4b0ec6fcf4b6474d22307baa04f8f515 (diff)
CvcParserBlack and supporting Makefile changes
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f429e8b2a..110ab9855 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,10 +24,15 @@ SUBDIRS = util expr context prop smt theory . parser main
lib_LTLIBRARIES = libcvc4.la
+noinst_LTLIBRARIES = libcvc4_noinst.la
+
libcvc4_la_LDFLAGS = -version-info $(LIBCVC4_VERSION) -release $(LIBCVC4_RELEASE)
libcvc4_la_SOURCES =
-libcvc4_la_LIBADD = \
+libcvc4_la_LIBADD = libcvc4_noinst.la
+
+libcvc4_noinst_la_SOURCES =
+libcvc4_noinst_la_LIBADD = \
@builddir@/util/libutil.la \
@builddir@/expr/libexpr.la \
@builddir@/context/libcontext.la \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback