summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-07-16 19:00:31 +0000
committerMorgan Deters <mdeters@gmail.com>2012-07-16 19:00:31 +0000
commit1f8da4ffd0887a095994392087d76f376ac006d2 (patch)
treee1c94f40b721bf386eaa791de5cd9a13b0b2966a /src/Makefile.am
parent5ad6726028477de6059a0af83b8870d9d524a7ac (diff)
now passes "make distcheck", which does important checks for the release (e.g., "make dist" produces a distribution that passes "make dist" and "make check", "make uninstall" actually uninstalls, "make distclean" actually cleans, ...)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 818acfa29..e04910804 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -146,3 +146,31 @@ uninstall-local:
-rmdir "$(DESTDIR)$(includedir)/cvc4/bindings"
-rmdir "$(DESTDIR)$(includedir)/cvc4"
-rmdir "$(DESTDIR)$(libdir)/ocaml/cvc4"
+
+# clean up the .fix files
+mostlyclean-local:
+ (echo include/cvc4.h; \
+ echo include/cvc4_public.h; \
+ echo include/cvc4parser_public.h; \
+ find * -name '*.h.fix' | \
+ xargs grep -l '^# *include *<cvc4/cvc4.*_public\.h>' | \
+ sed 's,\.fix$$,,'; \
+ (cd "$(srcdir)" && find * -name '*.h' | \
+ xargs grep -l '^# *include *"cvc4.*_public\.h"')) | \
+ while read f; do \
+ if expr "$$f" : ".*_\(template\|private\|test_utils\)\.h$$" &>/dev/null; then \
+ continue; \
+ fi; \
+ d="$$(echo "$$f" | sed 's,^include/,,')"; \
+ if [ -e "$$f" ]; then \
+ path="$$f"; \
+ fixpath="$$f.fix"; \
+ else \
+ path="$(srcdir)/$$f"; \
+ fixpath="$(builddir)/$$f.fix"; \
+ $(MKDIR_P) "`dirname "$$fixpath"`"; \
+ fi; \
+ echo rm -f "$$fixpath"; \
+ rm -f "$$fixpath"; \
+ done
+
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback