summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2011-09-24 18:04:08 +0000
committerMorgan Deters <mdeters@gmail.com>2011-09-24 18:04:08 +0000
commitb79e8b369649f053ce3a39d3d178e4e2dbcf9993 (patch)
tree0d75973130594b7b498cee4dc60b83a267fbad2d /src/Makefile.am
parenta63064385c56600143ac470108fe8e640a4ca3ee (diff)
Fix to building and linking for unit tests. (This should fix the segfaulting units in optimized-dynamic. The problem was that the code incorrectly determined the address of one of the thread-scoped global variables, and I think it's because the same library was linked twice into the unit test in two different ways, confusing the runtime support code.)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 199accf85..4244bd053 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,7 +21,7 @@ SUBDIRS = lib expr util context theory prop smt printer . parser compat bindings
lib_LTLIBRARIES = libcvc4.la
if HAVE_CXXTESTGEN
-noinst_LTLIBRARIES = libcvc4_noinst.la
+check_LTLIBRARIES = libcvc4_noinst.la
endif
libcvc4_la_LDFLAGS = -version-info $(LIBCVC4_VERSION)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback