summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-10-27 05:48:49 +0000
committerMorgan Deters <mdeters@gmail.com>2010-10-27 05:48:49 +0000
commit80c215636795a12fbab3544f5882a65e5e562041 (patch)
treeb0eac074ed940bb57bc89467acfcfc7797413a45 /src/Makefile.am
parent12ce65216cf464f4a894ca4640895d29a638d681 (diff)
"make dist" fixes; a distribution tarball can now build and pass tests. "make distcheck" fails only because one of the "clean" targets needs work in test/unit
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 944600c81..a46f56598 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -70,6 +70,7 @@ install-data-local: $(publicheaders)
uninstall-local:
@for f in $(publicheaders); do \
- rm -f "$(DESTDIR)/$(includedir)/cvc4/$$f"
+ f=`echo "$$f" | sed 's,.*/,,'`; \
+ rm -f "$(DESTDIR)$(includedir)/cvc4/$$f"; \
done
- rmdir "$(DESTDIR)/$(includedir)/cvc4"
+ @rmdir "$(DESTDIR)$(includedir)/cvc4"
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback