summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@google.com>2016-01-28 12:35:45 -0800
committerTim King <taking@google.com>2016-01-28 12:35:45 -0800
commit2ba8bb701ce289ba60afec01b653b0930cc59298 (patch)
tree46df365b7b41ce662a0f94de5b11c3ed20829851 /src/Makefile.am
parent42b665f2a00643c81b42932fab1441987628c5a5 (diff)
Adding listeners to Options.
- Options -- Added the new option attribute :notify. One can get a notify() call on the Listener after a the option's value is updated. This is the new preferred way to achieve dynamic dispatch for options. -- Removed SmtOptionsHandler and pushed its functionality into OptionsHandler and Listeners. -- Added functions to Options for registering listeners of the notify calls. -- Changed a number of options to use the new listener infrastructure. -- Fixed a number of warnings in options. -- Added the ArgumentExtender class to better capture how arguments are inserted while parsing options and ease memory management. Previously this was the "preemptGetopt" procedure. -- Moved options/options_handler_interface.{cpp,h} to options/options_handler.{cpp,h}. - Theories -- Reimplemented alternative theories to use a datastructure stored on TheoryEngine instead of on Options. - Ostream Handling: -- Added new functionality that generalized how ostreams are opened, options/open_stream.h. -- Simplified the memory management for different ostreams, smt/managed_ostreams.h. -- Had the SmtEnginePrivate manage the memory for the ostreams set by options. -- Simplified how the setting of ostreams are updated, smt/update_ostream.h. - Configuration and Tags: -- Configuration can now be used during predicates and handlers for options. -- Moved configuration.{cpp,h,i} and configuration_private.h from util/ into base/. -- Moved {Debug,Trace}_tags.* from being generated in options/ into base/. - cvc4_private.h -- Upgraded #warning's in cvc4_private.h and cvc4_private_library.h to #error's. -- Added public first-order (non-templatized) member functions for options get and set the value of options outside of libcvc4. Fixed all of the use locations. -- Made lib/lib/clock_gettime.h a cvc4_private_library.h header. - Antlr -- Fixed antlr and cvc4 macro definition conflicts that caused warnings. - SmtGlobals -- Refactored replayStream and replayLog out of SmtGlobals. -- Renamed SmtGlobals to LemmaChannels and moved the implementation into smt_util/lemma_channels.{h,cpp}.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am31
1 files changed, 15 insertions, 16 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c71caea51..3f573f55e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -105,26 +105,25 @@ libcvc4_la_SOURCES = \
prop/sat_solver_types.h \
prop/sat_solver_factory.h \
prop/sat_solver_factory.cpp \
- smt/smt_engine.cpp \
- smt/smt_engine_check_proof.cpp \
- smt/smt_engine.h \
- smt/smt_globals.cpp \
- smt/smt_globals.h \
+ smt/boolean_terms.cpp \
+ smt/boolean_terms.h \
+ smt/command_list.cpp \
+ smt/command_list.h \
+ smt/logic_exception.h \
+ smt/logic_request.cpp \
+ smt/logic_request.h \
+ smt/managed_ostreams.cpp \
+ smt/managed_ostreams.h \
smt/model_postprocessor.cpp \
smt/model_postprocessor.h \
+ smt/smt_engine.cpp \
+ smt/smt_engine.h \
+ smt/smt_engine_check_proof.cpp \
smt/smt_engine_scope.cpp \
smt/smt_engine_scope.h \
- smt/smt_options_handler.cpp \
- smt/smt_options_handler.h \
smt/smt_statistics_registry.cpp \
smt/smt_statistics_registry.h \
- smt/command_list.cpp \
- smt/command_list.h \
- smt/boolean_terms.h \
- smt/boolean_terms.cpp \
- smt/logic_exception.h \
- smt/logic_request.h \
- smt/logic_request.cpp \
+ smt/update_ostream.h \
theory/logic_info.h \
theory/logic_info.cpp \
theory/output_channel.h \
@@ -520,7 +519,7 @@ svn_versioninfo.cpp: svninfo
rev=0; \
mods=false; \
fi; \
- echo "#include \"util/configuration.h\""; \
+ echo "#include \"base/configuration.h\""; \
echo "const bool ::CVC4::Configuration::IS_SUBVERSION_BUILD = $$issvn;"; \
echo "const char* const ::CVC4::Configuration::SUBVERSION_BRANCH_NAME = \"$$branch\";"; \
echo "const unsigned ::CVC4::Configuration::SUBVERSION_REVISION = $$rev;"; \
@@ -548,7 +547,7 @@ git_versioninfo.cpp: gitinfo
rev=unknown; \
mods=false; \
fi; \
- echo "#include \"util/configuration.h\""; \
+ echo "#include \"base/configuration.h\""; \
echo "const bool ::CVC4::Configuration::IS_GIT_BUILD = $$isgit;"; \
echo "const char* const ::CVC4::Configuration::GIT_BRANCH_NAME = \"$$branch\";"; \
echo "const char* const ::CVC4::Configuration::GIT_COMMIT = \"$$rev\";"; \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback