summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@google.com>2015-11-02 17:30:52 -0500
committerTim King <taking@google.com>2015-11-03 00:30:15 -0500
commit539be0858a42508e2a990521280fa6c17186768a (patch)
tree4cf513ff0d2bf37b9ff945c7f436c498ce79000e /src/Makefile.am
parent5bc200446b4165814db47e6e3639972af31ad0a6 (diff)
Adding a test to ensure the <build>/src/theory directory is available to the scripts in src/Makefile.am. This should fix a bug in building the debian packages.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 67d405765..3c482413b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -647,12 +647,8 @@ $(top_builddir)/src/.subdirs: $(top_srcdir)/src/Makefile.theories @top_srcdir@/
$(am__mv) $(top_builddir)/src/.subdirs.tmp $(top_builddir)/src/.subdirs; \
fi
-# $(AM_V_at)(\
-# grep '^THEORIES = ' $(top_srcdir)/src/Makefile.theories | \
-# cut -d' ' -f3- | tr ' ' "\n" | \
-# xargs -I__D__ echo $(top_srcdir)/src/theory/__D__/kinds ) >$(top_builddir)/src/.subdirs.tmp
-
theory/rewriter_tables.h: theory/rewriter_tables_template.h theory/mkrewriter @top_builddir@/src/.subdirs @top_srcdir@/src/theory/*/kinds
+ $(AM_V_at)test -d $(top_builddir)/src/theory || mkdir -p @top_builddir@/src/theory
$(AM_V_at)chmod +x @srcdir@/theory/mkrewriter
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/theory/mkrewriter \
@@ -661,6 +657,7 @@ theory/rewriter_tables.h: theory/rewriter_tables_template.h theory/mkrewriter @t
> $@) || (rm -f $@ && exit 1)
theory/theory_traits.h: theory/theory_traits_template.h theory/mktheorytraits @top_builddir@/src/.subdirs @top_srcdir@/src/theory/*/kinds
+ $(AM_V_at)test -d $(top_builddir)/src/theory || mkdir -p @top_builddir@/src/theory
$(AM_V_at)chmod +x @srcdir@/theory/mktheorytraits
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/theory/mktheorytraits \
@@ -669,6 +666,7 @@ theory/theory_traits.h: theory/theory_traits_template.h theory/mktheorytraits @t
> $@) || (rm -f $@ && exit 1)
theory/type_enumerator.cpp: theory/type_enumerator_template.cpp theory/mktheorytraits @top_builddir@/src/.subdirs @top_srcdir@/src/theory/*/kinds
+ $(AM_V_at)test -d $(top_builddir)/src/theory || mkdir -p @top_builddir@/src/theory
$(AM_V_at)chmod +x @srcdir@/theory/mktheorytraits
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
$(AM_V_GEN)(@srcdir@/theory/mktheorytraits \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback