summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2011-09-17 01:57:27 +0000
committerMorgan Deters <mdeters@gmail.com>2011-09-17 01:57:27 +0000
commit35c358f086dc16604e506028c1c288172edd1409 (patch)
tree15ab0e8613a419ee1c48825ee8096976142aceb2 /src/Makefile.am
parent84f0e9f58671083794dce8ed8e71a8fa9fe587cd (diff)
--show-debug-tags and --show-trace-tags now supported by Configuration API; also, the information is only recompiled and relinked when it has changed, avoiding unnecessary relinking
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9ffe249ee..e6c00c943 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -78,9 +78,11 @@ subversion_versioninfo.cpp: svninfo
echo "const unsigned ::CVC4::Configuration::SUBVERSION_REVISION = $$rev;"; \
echo "const bool ::CVC4::Configuration::SUBVERSION_HAS_MODIFICATIONS = $$mods;"; \
) >"$@"
+# This .tmp business is to keep from having to re-compile options.cpp
+# (and then re-link the libraries) if nothing has changed.
svninfo: svninfo.tmp
$(AM_V_GEN)diff -q svninfo.tmp svninfo &>/dev/null || mv svninfo.tmp svninfo || true
-# .PHONY ensures it's always rebuilt
+# .PHONY ensures the .tmp version is always rebuilt (to check for any changes)
.PHONY: svninfo.tmp
svninfo.tmp:
$(AM_V_GEN)(cd "$(top_srcdir)" && svn info && echo "Modifications: `test -z \"\`svn status -q\`\" && echo false || echo true`") >"$@" 2>/dev/null || true
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback