summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2018-06-20 13:32:18 -0700
committerGitHub <noreply@github.com>2018-06-20 13:32:18 -0700
commit13253bf7fe9d024bfeccf2d1b169ed78970a1acf (patch)
tree77df6a092634963e7f7086a72c83b3f4cb4a80f7 /src/Makefile.am
parent06f9525d675048ba7d945c8d9acdf84896eb5fbb (diff)
Resolve CVC4_USE_SYMFPU in headers at config-time (#2077)
As described in issue #2013, we had `#ifdef CVC4_USE_SYMFPU` conditions in floatingpoint.h, which was problematic when installing the header files because the definition of `CVC4_USE_SYMFPU` was a compile-flag and simply including the header files in another project would be missing that definition. This commit moves floatingpoint.h to a template file floatingpoint.h.in and substitutes the value of `CVC4_USE_SYMFPU` at configure-time when generating floatingpoint.h (this is the same solution that integer.h and rational.h use). I have tested the fix with the examples provided in #2013 and they work.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index aa4487c42..ce9f74d9e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -727,6 +727,7 @@ install-data-local:
(echo include/cvc4.h; \
echo include/cvc4_public.h; \
echo include/cvc4parser_public.h; \
+ echo util/floatingpoint.h; \
echo util/integer.h; \
echo util/rational.h; \
find * -name '*.h' | \
@@ -759,6 +760,7 @@ uninstall-local:
-(echo include/cvc4.h; \
echo include/cvc4_public.h; \
echo include/cvc4parser_public.h; \
+ echo util/floatingpoint.h; \
echo util/integer.h; \
echo util/rational.h; \
find * -name '*.h' | \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback