summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-04-02 12:48:44 -0700
committerAina Niemetz <aina.niemetz@gmail.com>2018-04-02 12:48:44 -0700
commita917cc2ab4956b542b1f565abf0e62b197692f8d (patch)
tree7579ae2a631696fcfe750f8d29a56871af519185 /src/Makefile.am
parent2d40d7ade3c66ba10a1f20ae5ab014aed8e2df01 (diff)
Reorganize bitblaster code. (#1695)
This splits bitblaster_template.h into the separate header files {aig,eager,lazy}_bitblaster.h and bitblaster.h (the template class TBitblaster). All the bitblaster related code is moved into the sub-directory bitblast/.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6693deaa5..2beb8274d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -292,10 +292,15 @@ libcvc4_la_SOURCES = \
theory/builtin/type_enumerator.h \
theory/bv/abstraction.cpp \
theory/bv/abstraction.h \
- theory/bv/aig_bitblaster.cpp \
- theory/bv/bitblast_strategies_template.h \
- theory/bv/bitblast_utils.h \
- theory/bv/bitblaster_template.h \
+ theory/bv/bitblast/aig_bitblaster.cpp \
+ theory/bv/bitblast/aig_bitblaster.h \
+ theory/bv/bitblast/bitblast_strategies_template.h \
+ theory/bv/bitblast/bitblast_utils.h \
+ theory/bv/bitblast/bitblaster.h \
+ theory/bv/bitblast/eager_bitblaster.cpp \
+ theory/bv/bitblast/eager_bitblaster.h \
+ theory/bv/bitblast/lazy_bitblaster.cpp \
+ theory/bv/bitblast/lazy_bitblaster.h \
theory/bv/bv_eager_solver.cpp \
theory/bv/bv_eager_solver.h \
theory/bv/bv_inequality_graph.cpp \
@@ -317,8 +322,6 @@ libcvc4_la_SOURCES = \
theory/bv/bvgauss.h \
theory/bv/bvintropow2.cpp \
theory/bv/bvintropow2.h \
- theory/bv/eager_bitblaster.cpp \
- theory/bv/lazy_bitblaster.cpp \
theory/bv/slicer.cpp \
theory/bv/slicer.h \
theory/bv/theory_bv.cpp \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback