summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2013-02-07 13:58:22 -0500
committerMorgan Deters <mdeters@cs.nyu.edu>2013-02-07 13:58:51 -0500
commit98eec3152a2b24dc0cc04cd1ea595e400cca203e (patch)
treed492a680ebcb15e0e470383499607ce51532e71c /src/Makefile.am
parent816630a9e9e6b13f7299535a18fe87c5f8180def (diff)
Do not install the "private-library" header
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 40d3823e9..1d54bc2a8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -120,7 +120,7 @@ install-data-local:
(cd "$(srcdir)" && find * -name '*.h' | \
xargs grep -l '^# *include *"cvc4.*_public\.h"')) | \
while read f; do \
- if expr "$$f" : ".*_\(template\|private\|test_utils\)\.h$$" &>/dev/null; then \
+ if expr "$$f" : ".*_\(template\|private\|private_library\|test_utils\)\.h$$" &>/dev/null; then \
continue; \
fi; \
d="$$(echo "$$f" | sed 's,^include/,,')"; \
@@ -150,7 +150,7 @@ uninstall-local:
(cd "$(srcdir)" && find * -name '*.h' | \
xargs grep -l '^# *include *"cvc4.*_public\.h"')) | \
while read f; do \
- if expr "$$f" : ".*_\(template\|private\|test_utils\)\.h$$" &>/dev/null; then \
+ if expr "$$f" : ".*_\(template\|private\|private_library\|test_utils\)\.h$$" &>/dev/null; then \
continue; \
fi; \
d="$$(echo "$$f" | sed 's,^include/,,')"; \
@@ -175,7 +175,7 @@ mostlyclean-local:
(cd "$(srcdir)" && find * -name '*.h' | \
xargs grep -l '^# *include *"cvc4.*_public\.h"')) | \
while read f; do \
- if expr "$$f" : ".*_\(template\|private\|test_utils\)\.h$$" &>/dev/null; then \
+ if expr "$$f" : ".*_\(template\|private\|private_library\|test_utils\)\.h$$" &>/dev/null; then \
continue; \
fi; \
d="$$(echo "$$f" | sed 's,^include/,,')"; \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback