summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-04-08 20:49:11 +0000
committerMorgan Deters <mdeters@gmail.com>2010-04-08 20:49:11 +0000
commitc3a6ff8c6e4a0c743cd33eb29931f837eeb2959e (patch)
treedf8d8a97baebea55aaf94cc816974a86475c3a4b /src/Makefile.am
parentde2b6c4ee9c2ecad88bddd0a60f10e94d6f8c71f (diff)
A handful of build system fixes:
* (test/unit/Makefile.am) libtool was being passed relative paths of sources in .cpp, confusing lcov if -b wasn't given. Fixed. Closes bug #102. * (configure.ac) --enable-coverage now implies --enable-static --enable-static-binary --disable-shared. * (configure.ac) Create top-level config.status for informational and re-configuration purposes. * (configure.ac) Remove -fvisibility=hidden for debug builds. Closes bug #104. * (test/unit/Makefile.am) Build unit tests with -Wall. * (various unit tests) Fixed trivially-fixable warnings in building unit tests. (Signedness in comparison, unused variables, etc.) * (Makefile.builds.in) Copy the binary correctly if it is static. (It was failing, but only with --enable-static --enable-shared --enable-static-binary.) Closes bug #103. * (src/parser/Makefile.am) libcvc4parser.so now links with libcvc4.so. * Other minor cleanups to the build system.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 593499c9b..cb529dcde 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -55,7 +55,3 @@ install-data-local: $(publicheaders)
echo $(INSTALL_DATA) "$(srcdir)/$$f" "$(DESTDIR)/$(includedir)/cvc4"; \
$(INSTALL_DATA) "$(srcdir)/$$f" "$(DESTDIR)/$(includedir)/cvc4"; \
done
-
-include/cvc4.h: smt/smt_engine.h
- @srcdir@/headergen.pl $< $@
-include/cvc4_expr.h: expr/expr.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback