summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2009-12-17 22:11:37 +0000
committerMorgan Deters <mdeters@gmail.com>2009-12-17 22:11:37 +0000
commit093492af43fae12d7f1d4607e63b1da686044ea6 (patch)
treed27effb35d74a299dc135b9ee85f3adc2b065061 /src/Makefile.am
parentdfcf7dba0b2d8ad6eb9d8540e92804e70205b8fb (diff)
more build system fix-ups
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 110ab9855..97a2ecead 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -27,11 +27,15 @@ lib_LTLIBRARIES = libcvc4.la
noinst_LTLIBRARIES = libcvc4_noinst.la
libcvc4_la_LDFLAGS = -version-info $(LIBCVC4_VERSION) -release $(LIBCVC4_RELEASE)
+libcvc4_la_LINK = $(CXXLINK)
libcvc4_la_SOURCES =
libcvc4_la_LIBADD = libcvc4_noinst.la
-libcvc4_noinst_la_SOURCES =
+# empty.cpp is a fake file added to "trick" automake into linking us as a
+# C++ library (rather than as a C library, which messes up exception
+# handling support)
+libcvc4_noinst_la_SOURCES = empty.cpp
libcvc4_noinst_la_LIBADD = \
@builddir@/util/libutil.la \
@builddir@/expr/libexpr.la \
@@ -41,6 +45,9 @@ libcvc4_noinst_la_LIBADD = \
@builddir@/smt/libsmt.la \
@builddir@/theory/libtheory.la
+# empty.cpp hack; see above
+empty.cpp:; touch empty.cpp
+
publicheaders = \
include/cvc4_config.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback