summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2018-04-19 11:47:38 -0700
committerGitHub <noreply@github.com>2018-04-19 11:47:38 -0700
commit70046d35f2aff41867cbb6490e5bf6d026dc55a1 (patch)
treea6903beb73a028ea159b07bb5c773386c1e5c5f5 /src/Makefile.am
parent4af9af22f728ebb12afe48c587cfe665fc8cb123 (diff)
Refactor pbRewrites preprocessing pass (#1767)
This commit refactors the pbRewrites preprocessing pass into the new style. This commit is essentially just a code move and adds a regression test for the preprocessing pass. It also makes use of the AssertionPipeline::replace function to do proper dependency tracking.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 67e105089..f89a8426e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -62,10 +62,12 @@ libcvc4_la_SOURCES = \
decision/decision_strategy.h \
decision/justification_heuristic.cpp \
decision/justification_heuristic.h \
- preprocessing/passes/int_to_bv.cpp \
- preprocessing/passes/int_to_bv.h \
preprocessing/passes/bv_gauss.cpp \
preprocessing/passes/bv_gauss.h \
+ preprocessing/passes/int_to_bv.cpp \
+ preprocessing/passes/int_to_bv.h \
+ preprocessing/passes/pseudo_boolean_processor.cpp \
+ preprocessing/passes/pseudo_boolean_processor.h \
preprocessing/preprocessing_pass.cpp \
preprocessing/preprocessing_pass.h \
preprocessing/preprocessing_pass_context.cpp \
@@ -246,8 +248,6 @@ libcvc4_la_SOURCES = \
theory/arith/normal_form.h\
theory/arith/partial_model.cpp \
theory/arith/partial_model.h \
- theory/arith/pseudoboolean_proc.cpp \
- theory/arith/pseudoboolean_proc.h \
theory/arith/simplex.cpp \
theory/arith/simplex.h \
theory/arith/simplex_update.cpp \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback