summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2017-11-30 15:50:00 -0800
committerGitHub <noreply@github.com>2017-11-30 15:50:00 -0800
commit4c1f1cad720a94226f7834874cf59478de35b74a (patch)
treeb97655661092e2597b31c089ec9bc52e77d33ec9 /src/Makefile.am
parent89b6c052e96cc907800650de93d2f238e19acd38 (diff)
Add Gaussian Elimination as a preprocessing pass for BV. (#1342)
This adds Gaussian Elimination as a preprocessing pass for BV. Gaussian Elimination is only applied if the given bit-width guarantees that no overflows can occur.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f50893497..6a21251bd 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -306,6 +306,8 @@ libcvc4_la_SOURCES = \
theory/bv/bv_subtheory_inequality.h \
theory/bv/bv_to_bool.cpp \
theory/bv/bv_to_bool.h \
+ theory/bv/bvgauss.cpp \
+ theory/bv/bvgauss.h \
theory/bv/bvintropow2.cpp \
theory/bv/bvintropow2.h \
theory/bv/cd_set_collection.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback