summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Brain <martin.brain@cs.ox.ac.uk>2014-12-03 21:29:43 -0500
committerMorgan Deters <mdeters@cs.nyu.edu>2014-12-03 21:58:28 -0500
commitcf6bc6c57dd579b8f75b7d20922eda0eaa92b2f7 (patch)
tree582afecddf7d64953d8562ab57dd915db6cc852f /src/Makefile.am
parent2121eaac7e63875f1e6ba53076535d25fd561c04 (diff)
Floating point infrastructure.
Signed-off-by: Morgan Deters <mdeters@cs.nyu.edu>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f88dcb3a9..e66d590dc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -20,7 +20,7 @@ AM_CPPFLAGS = \
AM_CXXFLAGS = -Wall -Wno-unknown-pragmas -Wno-parentheses $(FLAG_VISIBILITY_HIDDEN)
SUBDIRS = lib options expr util prop/minisat prop/bvminisat . parser compat bindings main
-THEORIES = builtin booleans uf arith bv arrays datatypes sets strings quantifiers idl
+THEORIES = builtin booleans uf arith bv fp arrays datatypes sets strings quantifiers idl
lib_LTLIBRARIES = libcvc4.la
@@ -407,7 +407,12 @@ libcvc4_la_SOURCES = \
theory/booleans/circuit_propagator.cpp \
theory/booleans/boolean_term_conversion_mode.h \
theory/booleans/boolean_term_conversion_mode.cpp \
- theory/booleans/options_handlers.h
+ theory/booleans/options_handlers.h \
+ theory/fp/theory_fp.h \
+ theory/fp/theory_fp.cpp \
+ theory/fp/theory_fp_rewriter.h \
+ theory/fp/theory_fp_rewriter.cpp \
+ theory/fp/theory_fp_type_rules.h
nodist_libcvc4_la_SOURCES = \
smt/smt_options.cpp \
@@ -491,7 +496,9 @@ EXTRA_DIST = \
theory/example/ecdata.h \
theory/example/ecdata.cpp \
theory/example/theory_uf_tim.h \
- theory/example/theory_uf_tim.cpp
+ theory/example/theory_uf_tim.cpp \
+ theory/fp/kinds \
+ theory/fp/options_handlers.h
svn_versioninfo.cpp: svninfo
$(AM_V_GEN)( \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback