summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-10-01 21:35:31 +0000
committerMorgan Deters <mdeters@gmail.com>2010-10-01 21:35:31 +0000
commit96d1c3daff7efdd2d853864fb820bc7cf413624e (patch)
treeb995c98a2be18182d6cb52e81de5bf712b475f06 /src/Makefile.am
parentd0b49d588033ab8140bdf297c9cdf73b1088fe68 (diff)
replacement implementation for clock_gettime() on mac os x, build portability (resolving mac os x issues), code cleanup, fix compiler warnings
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e436971fa..fb337e204 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,12 +12,12 @@
#
LIBCVC4_VERSION = @CVC4_LIBRARY_VERSION@
-AM_CPPFLAGS =
+AM_CPPFLAGS = \
-D__BUILDING_CVC4LIB \
-I@srcdir@/include -I@srcdir@ -I@builddir@
AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
-SUBDIRS = expr util context theory prop smt . parser main
+SUBDIRS = lib expr util context theory prop smt . parser main
lib_LTLIBRARIES = libcvc4.la
@@ -40,7 +40,8 @@ libcvc4_noinst_la_LIBADD = \
@builddir@/prop/libprop.la \
@builddir@/prop/minisat/libminisat.la \
@builddir@/smt/libsmt.la \
- @builddir@/theory/libtheory.la
+ @builddir@/theory/libtheory.la \
+ @builddir@/lib/libreplacements.la
EXTRA_DIST = \
include/cvc4parser_private.h \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback