summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-11-11 12:56:03 -0600
committerGitHub <noreply@github.com>2020-11-11 12:56:03 -0600
commit80930ce4f6d21b417028a5ec207ddfbd7d85e66d (patch)
tree6c616c78fc05609983d1d4742fa5d0e69b8aa22e /src/CMakeLists.txt
parent7d3198d18304eb6ea5f087a82defb4952fce31b9 (diff)
Move symbol manager to src/expr/ (#5420)
This is required since symbol manager will use context dependent data structures (in its cpp). This is required since classes in src/parser/ are not allowed to include private headers.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1a06e9366..c1e39f47e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1128,6 +1128,7 @@ install(FILES
expr/expr_iomanip.h
expr/record.h
expr/sequence.h
+ expr/symbol_manager.h
expr/symbol_table.h
expr/type.h
expr/uninterpreted_constant.h
@@ -1151,7 +1152,6 @@ install(FILES
parser/parser_builder.h
parser/parser_exception.h
parser/parse_op.h
- parser/symbol_manager.h
DESTINATION
${CMAKE_INSTALL_INCLUDEDIR}/cvc4/parser)
install(FILES
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback