summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2021-07-06 17:44:09 -0500
committerGitHub <noreply@github.com>2021-07-06 17:44:09 -0500
commit4ac6c5179265ef9895bc9e939be0e47b3754137e (patch)
treebf2cd175a534e5ca9a383a63cd6a086f1d5f45d0 /src/CMakeLists.txt
parentb023494b8914be03d8f8ca26c1b1db332944f3fe (diff)
Integrate learned rewrite preprocessing pass (#6840)
This adds the learned rewrite preprocessing pass, which rewrites the input formula based on (typically theory specific) reasoning about learned literals. The main motivation is for preprocessing ints division/modulus based on bounds.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 74db7c941..3246df654 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -88,6 +88,8 @@ libcvc5_add_sources(
preprocessing/passes/ite_removal.h
preprocessing/passes/ite_simp.cpp
preprocessing/passes/ite_simp.h
+ preprocessing/passes/learned_rewrite.cpp
+ preprocessing/passes/learned_rewrite.h
preprocessing/passes/miplib_trick.cpp
preprocessing/passes/miplib_trick.h
preprocessing/passes/nl_ext_purify.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback