summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <nafur42@gmail.com>2021-10-11 10:48:09 -0700
committerGitHub <noreply@github.com>2021-10-11 17:48:09 +0000
commit4b7781d90ead61d9478aabd6a4c229a114483679 (patch)
tree4de89ebc81a28d8ce56ffda2f99ccf606dbd983a /src/CMakeLists.txt
parent0ddbf090c7f7f33ce724df456daecf84d807e793 (diff)
Revert #7257 (#7337)
This PR reverts #7257 and restores compatibility with ancient glibc versions.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4c418d928..583ce8bc5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1349,6 +1349,14 @@ if(ENABLE_STATIC_LIBRARY)
target_link_libraries(cvc5-static PUBLIC GMP_STATIC)
endif()
+# Add rt library
+# Note: For glibc < 2.17 we have to additionally link against rt (man clock_gettime).
+# RT_LIBRARIES should be empty for glibc >= 2.17
+target_link_libraries(cvc5-shared PRIVATE ${RT_LIBRARIES})
+if(ENABLE_STATIC_LIBRARY)
+ target_link_libraries(cvc5-static PRIVATE ${RT_LIBRARIES})
+endif()
+
if(ENABLE_VALGRIND)
target_include_directories(cvc5-obj PUBLIC ${Valgrind_INCLUDE_DIR})
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback