summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-08-06 08:29:17 -0500
committerGitHub <noreply@github.com>2020-08-06 08:29:17 -0500
commit956ffda5632b388a887003a5e030696091339bd2 (patch)
tree130b34e344ad9fa072d5c388132da0c5d0105c05 /src/CMakeLists.txt
parent77e98815254c68301ffcd7fb8addeb6751c51187 (diff)
Split preprocessor from SmtEngine (#4854)
This splits a collection of utilities from SmtEngine that work in cooperation to preprocess assertions (Boolean circuit propagator, preprocessing context, process assertions, term formula removal). It updates various interfaces in SmtEngine from Expr -> Node and simplifies SmtEngine to use this utility.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 92f197252..6bbc2d29b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -249,6 +249,8 @@ libcvc4_add_sources(
smt/model_blocker.h
smt/options_manager.cpp
smt/options_manager.h
+ smt/preprocessor.cpp
+ smt/preprocessor.h
smt/preprocess_proof_generator.cpp
smt/preprocess_proof_generator.h
smt/process_assertions.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback