summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-08-24 13:16:04 -0500
committerGitHub <noreply@github.com>2020-08-24 13:16:04 -0500
commit6d53928cd9f16385d81124916311c372ec20b5ed (patch)
tree613e51c10005b401fd8b181bb94426c7d3834ab9 /src/CMakeLists.txt
parent983f41ea94f68e90d24e353ae3fd1aca04ac56ff (diff)
Add the distributed model manager (#4934)
This class is responsible for model building when using a distributed approach for equality engines. This PR defines the class but does not yet activate it in TheoryEngine. This includes some model-specific things from TheoryEngine which will be migrated to this class on the next PR.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c9eaede9a..83cd363f6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -508,6 +508,10 @@ libcvc4_add_sources(
theory/interrupted.h
theory/logic_info.cpp
theory/logic_info.h
+ theory/model_manager.cpp
+ theory/model_manager.h
+ theory/model_manager_distributed.cpp
+ theory/model_manager_distributed.h
theory/output_channel.cpp
theory/output_channel.h
theory/quantifiers/alpha_equivalence.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback